No input [pico proj...
Clear all

No input [pico projector]

2 Posts
1 Users
Posts: 2
New Member
Topic starter


I just got the pico projector with the extended battery.

All worked perfectly.

Then I started to load it with movies till it stated that there is no more space in the internal disk.

I just shut it off till the next morning.

When I turned it on afterwards. the pico projector says No signal....

I tried several buttons from the remote, but no one responded but the mute button.

While pressing it, the projector says no firmware detected....

PLEASE HELP to restore working condition.



Posted : 17/03/2023 12:12 am
Posts: 2
New Member
Topic starter
I managed to overcome the problem:
1. Waited enough time after the projector displayed the no signal sign without touching any button.
2. The projector finally started, and worked OK.
3. I shut down the projector. But when I started it again, it showed the same problem.
4. After the projector came up, I deleted some videos I uploaded.
5. Shut down the projector, then on again and it behaves normally
I guess that in some future firmware update, this issue will be prevented.
Posted : 17/03/2023 6:02 pm
Become Part of XDO

Become part of Pico PC venture by supporting our cause. We have successfullly gained alot of support from our customers and supporters. We need yours too. Join Us. 

Pico Pc Pantera Pico PC Newsletter

Get exclusive email offers, product release details, and more!

Order PicoPC now on InDemand >>

You have Successfully Subscribed!